Senin, 01 Maret 2010

Cara Mudah Membuat Router dengan OS Mikrotik

Pesiapan:
1) 2 Buah komputer (Router dan Client)
2) 3 Buah Lan Card (2 untuk Router Dan 1 Client)
3) CD Mikrotik
4) 2 Kabel Stright (Jika ke Switch semua) atau
1 Kabel Stright (ke Switch) 1 Cross ( ke komputer Client)

Eth0 :
IP :192.168.0.87
DNS :118.98.223.10
202.134.0.155
Gateway :192.168.0.1

Eth1 :
IP : 192.168.18.1

Langkah-langkah:
- Atur first boot di bios menjadi CD ROOM

1.Installasi software
Tekan ‘a’ untuk memilih semua, setelah itu tekan ‘i’.

- Setelah itu akan ada pilihan untuk reboot system dengan menekan’enter’

2.Installasi selesai

- Setelah itu login dengan user admin, dan password tidak di isi

3.Login

- Akan muncul pilihan untuk melihat licensi software. Kalau melihat tekan ‘y’ kalau tidak ‘n’

- Jika kita tekan y maka akan muncul

4.License

- Setelah itu atur ip address dengan perintah:
[admin@mikrotik] ip address add address=192.168.0.87 netmask=255.255.255.0 interface=ether1

[admin@mikrotik] ip address add address=192.168.18.1 netmask=255.255.255.0 interface=ether1

Ket: ether1=eth0
ether2=eth1
Untuk melihat konfigurasi IP
[admin@mikrotik] ip address print

5.IP Address

- Atur Gateway
[admin@mikrotik] ip route add gateway=192.168.0.1

Untuk melihat konfiguarsi gateway
[admin@mikrotik] ip route print

6.Gateway

- Atur DNS
[admin@mikrotik] > ip dns set primary-dns=202.134.1.10
[admin@mikrotik] > ip dns set primary-dns=202.134.0.155

Untuk cek DNS
[admin@mikrotik] > ip dns print

7.DNS

- Setelah itu coba ping ke www.google.com
[admin@mikrotik] > ping www.google.com

8.Ping

- Jika berhasil, berarti DNS sudah berhasil
- Setelah itu atur masquerading
[admin@mikrotik] > ip firewall nat add action=masquerade out-interface=ether1 chain=srcnat

Cara melihat configurasi masquerading
[admin@mikrotik] > ip firewall nat print

9.Masquerade

- Atur IP client dengan ip (192.168.18.2-254)
- Coba ping dari client ke Gateway dan ke google
Contoh: ping 192.168.0.1

10.Ping gateway

- Ping www.google.com

11.Ping google

- Sekarang kita coba setting Web-Proxy

[admin@MikroTik] >ip web-proxy
[admin@MikroTik] ip web-proxy> set enabled=yes
[admin@MikroTik] ip web-proxy> set src-address=0.0.0.0
[admin@MikroTik] ip web-proxy> set port=8080
[admin@MikroTik] ip web-proxy> set hostname=sofyan-sangar.com(hostname terserah)
[admin@MikroTik] ip web-proxy> set transparent-proxy=yes
[admin@MikroTik] ip web-proxy> set parent-proxy=0.0.0.0:0
[admin@MikroTik] ip web-proxy> set cache-administrator=sofyan@hadi.name(sesuai dengan alamat e-mail anda)
[admin@MikroTik] ip web-proxy> set max-object-size=512KB
[admin@MikroTik] ip web-proxy> set cache-drive=system
[admin@MikroTik] ip web-proxy> set max-cache-size=unlimited
[admin@MikroTik] ip web-proxy> set max-ram-cache-size=unlimited
[admin@MikroTik] ip web-proxy> /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080
[admin@MikroTik] ip web-proxy> /ip firewall nat add chain=dstnat protocol=tcp dst-port=3128 action=redirect to-ports=8080
[admin@MikroTik] ip web-proxy> /ip firewall nat add chain=dstnat protocol=tcp dst-port=8080 action=redirect to-ports=8080
Setelah proxy sudah di buat kita coba untuk memblokir situs :
[admin@MikroTik] ip web-proxy> access add url=www.yahoo.com method=any action=deny
16) Kalaw ingin ngeblok dengan kata
[admin@MikroTik] ip web-proxy> access add url=*porno* method=any action=deny
17) Semoga Sukses Teman teman dari sabang sampai Merauke

Saya sarankan membaca Referensi ini :
http://wiki.mikrotik.com
klik di sini

0 komentar:

Poskan Komentar

Share

Twitter Delicious Facebook Digg Stumbleupon Favorites